Search  
Register   Login Thursday, August 13, 2020
 
ForumForumMy Photo Index ...My Photo Index ...Bug reportsBug reports64-bit bug (I guess)64-bit bug (I guess)
Previous Previous
 
Next Next
New Post
 5/22/2008 5:46 AM
 

Hello,

I just downloaded this program, installed it and when I run it I got an exception:

System.InvalidOperationException: The 'Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine.

I did some fast research and discovered that this problem is due to being run on a x64 machine (it's running fine on a x86 laptop).

This issue can be easily solved simply by changing the Platform target from "Any CPU" to "x86". This can be done in the project properties - Build. Note that this can't be done in the Express edition of Visual Studio.

The first result I found about this was forums.microsoft.com/MSDN/ShowPost.aspx

In case you don't have access to Visual Studio Professional or any other version that allows you to change the Platform target I would be happy to compile that for you anytime. Just send an e-mail or something.

Hope I've been helpful.

New Post
 5/22/2008 1:04 PM
 

Hi,

Thanks for the help, I'll try to do this for the next version , I'm using VS pro so this should not be a problem,

In case I don't get a hold on a 64bit configuration, would it be possible for you to test this when the beta is available ?

Thanks,

Asaf.

New Post
 5/22/2008 11:53 PM
 

Sure, will be glad to test it.

Previous Previous
 
Next Next
ForumForumMy Photo Index ...My Photo Index ...Bug reportsBug reports64-bit bug (I guess)64-bit bug (I guess)

 
Membership Membership:
Latest New User Latest: zampetta
Past 24 Hours Past 24 Hours: 0
Prev. 24 Hours Prev. 24 Hours: 0
User Count Overall: 683

Online Now Online Now:
 
del.icio.us del.icio.us | technorati technorati | reddit reddit | stumbleupon stumbleupon | facebook facebook | live live
Copyright 2006-2014 by My Photo Index - the free open source photo organizer